setFrom Method
Set the x,y,z parts from one of these input types
- XYZ -- copy the x,y,z parts
- Float64Array -- Copy from indices 0,1,2 to x,y,z
- XY -- copy the x, y parts and set z=0
setFrom(other: undefined | Float64Array | Readonly<WritableXAndY> | Readonly<WritableXYAndZ>): void
Parameter | Type | Description |
---|---|---|
other | undefined | Float64Array | Readonly<WritableXAndY> | Readonly<WritableXYAndZ> |
Returns - void
Defined in
- geometry3d/Point3dVector3d.ts Line 115
Last Updated: 20 June, 2023