EntityState Class
The "state" of an Entity as represented in a web browser. Every subclass of EntityState handles one BIS class.
extensions
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: EntityProps, iModel: IModelConnection, _state?: EntityState): EntityState | Constructor for EntityState | |
clone(iModel?: IModelConnection): EntityState | Make an independent copy of this EntityState | |
equals(other: EntityState): boolean | Return true if this EntityState is equal to another one. |
Properties
Name | Type | Description | |
---|---|---|---|
classFullName Accessor StaticReadOnly | string | Get full BIS class name of this Entity in the form "SchemaName:ClassName". | |
classFullName Readonly | string | The full class name in the form "schema:class". | |
className Accessor ReadOnly | string | The name of the BIS class associated with this class. | |
className Accessor StaticReadOnly | string | The name of the BIS class associated with this class. | |
id Readonly | string | The Id of this Entity. | |
iModel Readonly | IModelConnection | The iModel from which this Entity was loaded | |
jsonProperties Readonly | { T } | Optional json properties of this Entity. | |
schemaName Accessor StaticReadOnly | string | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/EntityState.ts Line 17
Last Updated: 20 June, 2023