StandardView Class
Supplies access to a set of commonly-used view rotations.
Methods
Name | Description | |
---|---|---|
constructor(): StandardView | ||
adjustToStandardRotation(matrix: Matrix3d): void Static | Attempts to adjust the supplied rotation matrix to match the standard view rotation it most closely matches. | |
getStandardRotation(id: StandardViewId): Matrix3d Static | Obtain a Matrix3d corresponding to the specified StandardViewId. |
Properties
Name | Type | Description | |
---|---|---|---|
back Accessor StaticReadOnly | Matrix3d | ||
bottom Accessor StaticReadOnly | Matrix3d | ||
front Accessor StaticReadOnly | Matrix3d | ||
iso Accessor StaticReadOnly | Matrix3d | ||
left Accessor StaticReadOnly | Matrix3d | ||
right Accessor StaticReadOnly | Matrix3d | ||
rightIso Accessor StaticReadOnly | Matrix3d | ||
top Accessor StaticReadOnly | Matrix3d |
Defined in
Last Updated: 20 June, 2023