ViewStateProps Interface
Returned from IModelDb.Views.getViewStateData.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
categorySelectorProps | CategorySelectorProps | ||
displayStyleProps | DisplayStyleProps | ||
modelExtents | undefined | Range3dProps | For a DrawingViewState, the extents of the DrawingModel, used for determining the upper limits of the view's extents. | |
modelSelectorProps | undefined | ModelSelectorProps | ||
sectionDrawing | undefined | SectionDrawingViewProps | Information about the SectionDrawing relevant to displaying a drawing view. | |
sheetAttachments | undefined | Id64Array | The Ids of the ViewAttachments contained within the SheetModel, if this is a sheet view. | |
sheetProps | undefined | SheetProps | Sheet-specific properties, if this is a view of a SheetModel. | |
viewDefinitionProps | ViewDefinitionProps |
Defined in
- core/common/src/ViewProps.ts Line 94
Last Updated: 20 June, 2023