ModelDisplayTransformProvider Interface
Beta
Interface adopted by an object that wants to apply per-model display transforms. A model's display transform is applied when rendering the model in a Viewport.
see ViewState.modelDisplayTransformProvider to get or set the transform provider for a view.
see ViewState.computeDisplayTransform to compute a full display transform for a model or an element within it, which may include a transform supplied by a ModelDisplayTransformProvider.
Methods
Name | Description | |
---|---|---|
getModelDisplayTransform(modelId: string): undefined | Transform | Given the Id of a model, return the transform to be applied to it at display time, or undefined to apply no display transform. |
Defined in
- core/frontend/src/ViewState.ts Line 64
Last Updated: 20 June, 2023