computeDisplayTransform Method
Beta
Compute the transform applied to a model or element at display time, if any. The display transform may be constructed from any combination of the following:
- PlanProjectionSettings.elevation applied to plan projection models by DisplayStyle3dSettings.planProjectionSettings;
- A per-model transform supplied by this view's ViewState.modelDisplayTransformProvider; and/or
- A transform applied to an element by an RenderSchedule.ElementTimeline defined by this view's ViewState.scheduleScript.
computeDisplayTransform(args: ComputeDisplayTransformArgs): undefined | Transform
Parameter | Type | Description |
---|---|---|
args | ComputeDisplayTransformArgs | A description of how to compute the transform. |
Returns - undefined | Transform
The computed transform, or undefined
if no display transform is to be applied.
Defined in
- core/frontend/src/ViewState.ts Line 1289
Last Updated: 20 June, 2023