ComputeDisplayTransformArgs Interface
Beta
Arguments supplied to ViewState.computeDisplayTransform.
Properties
Name | Type | Description | |
---|---|---|---|
elementId | undefined | string | The Id of a specific element belonging to the model identified by ComputeDisplayTransformArgs.modelId for which to compute the display transform. | |
modelId | string | The Id of the model for which to compute the display transform. | |
output | undefined | Transform | If supplied, ViewState.computeDisplayTransform will modify and return this Transform to hold the result instead of allocating a new Transform. | |
timePoint | undefined | number | The point in time, expressed in Unix seconds, at which to evaluate the display transform. |
Defined in
- core/frontend/src/ViewState.ts Line 74
Last Updated: 20 June, 2023