AnalysisStyle Class
As part of a DisplayStyleSettings, describes how to animate meshes in the view that have been augmented with PolyfaceAuxData. The style specifies which channels to use, and can deform the meshes by translating vertices and/or recolor vertices using ThematicDisplay.
see DisplayStyleSettings.analysisStyle to define the analysis style for a DisplayStyle.
see DisplayStyleSettings.analysisFraction to control playback of the animation.
Methods
Name | Description | |
---|---|---|
clone(changedProps: AnalysisStyleProps): AnalysisStyle | Produce a copy of this style identical except for properties explicitly specified by changedProps . |
|
equals(other: AnalysisStyle): boolean | Return true if this style is equivalent to other . |
|
toJSON(): AnalysisStyleProps | Convert this style to its JSON representation. | |
fromJSON(props?: AnalysisStyleProps): AnalysisStyle Static | Create an analysis style from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults StaticReadonly | AnalysisStyle | ||
displacement Readonly | undefined | AnalysisStyleDisplacement | ||
normalChannelName Readonly | undefined | string | If defined, the name of the AuxChannel from which to obtain normal vectors for the vertices. | |
thematic Readonly | undefined | AnalysisStyleThematic |
Defined in
- core/common/src/AnalysisStyle.ts Line 203
Last Updated: 20 June, 2023