AuxChannel Class
Represents a single PolyfaceAuxData channel.
Methods
Name | Description | |
---|---|---|
constructor(data: AuxChannelData[], dataType: AuxChannelDataType, name?: string, inputName?: string): AuxChannel | Create a AuxChannel | |
clone(): AuxChannel | Return a deep copy. | |
computeDisplacementRange(scale: number = 1, result?: Range3d): Range3d | Compute the range of this channel's displacement values, if AuxChannel.dataType is AuxChannelDataType.Vector. | |
isAlmostEqual(other: AuxChannel, tol?: number): boolean | Toleranced comparison of contents. |
Properties
Name | Type | Description | |
---|---|---|---|
data | AuxChannelData[] | An array of AuxChannelData that represents the vertex data at one or more input values. | |
dataType | AuxChannelDataType | The type of data stored in this channel. | |
entriesPerValue Accessor ReadOnly | number | The number of values in data.values per entry - 1 for scalar and distance types, 3 for normal and vector types. |
|
inputName | undefined | string | The input name. | |
isScalar Accessor ReadOnly | boolean | True if AuxChannel.entriesPerValue is 1 . |
|
name | undefined | string | The channel name. | |
scalarRange Accessor ReadOnly | undefined | Range1d | The minimum and maximum values in data.values , or undefined if AuxChannel.isScalar is false. |
|
valueCount Accessor ReadOnly | number | The number of entries in data.values . |
Defined in
- polyface/AuxData.ts Line 84
Last Updated: 20 June, 2023