Name |
Description |
|
clipLinearMapToInterval(a: number, u: number, limitA: number, limitB: number): boolean |
clip this range to a linear half space condition |
|
clone(result?: Range1d): Range1d |
return a new Range1d with contents of this. |
|
cloneTranslated(delta: number, result?: Range1d): Range1d |
create a range with delta added to low and high |
|
containsRange(other: Range1d): boolean |
Test of other range is within this range |
|
containsX(x: number): boolean |
Test if a number is within the range. |
|
distanceToRange(other: Range1d): number |
returns 0 if the ranges have any overlap, otherwise the shortest absolute distance from one to the other. |
|
distanceToX(x: number): number |
Return 0 if the point is within the range, otherwise the (unsigned) distance to the closest face or corner |
|
expandInPlace(delta: number): void |
move all limits by a fixed amount. |
|
extendArray(values: number[] | Float64Array): void |
extend to include an array of values |
|
extendArraySubset(values: number[] | Float64Array, beginIndex: number, numValue: number): void |
extend to include values at indices beginIndex <= i < endIndex] |
|
extendHigh(x: number): boolean |
Extend only the high limit to x. |
|
extendLow(x: number): boolean |
Extend only the low limit to x. |
|
extendRange(other: Range1d): void |
Expand this range to include a range. |
|
extendX(x: number): void |
Expand this range by a single coordinate |
|
fractionToPoint(fraction: number): number |
return a point given by fractional positions within the range. |
|
intersect(other: Range1d, result?: Range1d): Range1d |
Return the intersection of ranges. |
|
intersectRangeXXInPlace(x0: number, x1: number): void |
Intersect this range with a range defined by parameters x0 and x1 |
|
intersectsRange(other: Range1d): boolean |
Test if there is any intersection with other range |
|
isAlmostEqual(other: Readonly<Range1d>): boolean |
Returns true if this and other have equal low and high parts, or both are null ranges. |
|
length(): number |
Return the length of the range in the x direction |
|
maxAbs(): number |
Return the largest absolute value among the box limits. |
|
scaleAboutCenterInPlace(scaleFactor: number): void |
move low and high points by scaleFactor around the center point. |
|
setFrom(other: Range1d): void |
copy contents from other Range1d. |
|
setFromJSON(json: Range1dProps): void |
Convert from a JSON object of one of these forms: |
|
setNull(): void |
reset the low and high to null range state. |
|
setX(x: number): void |
Set this range to be a single value. |
|
setXXUnordered(x0: number, x1: number): void |
Set this range to (min(x0,x1), max(x0,x1)) |
|
toJSON(): Range1dProps |
Convert to a JSON object of form |
|
union(other: Range1d, result?: Range1d): Range1d |
Return the union of ranges. |
|
createArray<T extends Range1d<T>>(values: number[] | Float64Array, result?: T): T Static |
Create a range containing all the values in an array. |
|
createFrom<T extends Range1d<T>>(other: T, result?: T): T Static |
return a new Range1d with contents of this. |
|
createNull<T extends Range1d<T>>(result?: T): T Static |
Create a range with no content. |
|
createX<T extends Range1d<T>>(x: number, result?: T): T Static |
Create a single point box |
|
createXX<T extends Range1d<T>>(xA: number, xB: number, result?: T): T Static |
Create a box from two values. |
|
createXXOrCorrectToNull<T extends Range1d<T>>(xA: number, xB: number, result?: T): T Static |
Create a box from two values, but null range if the values are reversed |
|
fromJSON<T extends Range1d<T>>(json?: Range1dProps): T Static |
Use setFromJSON to parse json into a new Range1d instance. |
|