PolyfaceAuxData Class
The PolyfaceAuxData
structure contains one or more analytical data channels for each vertex of a Polyface, allowing the polyface to be styled
using an AnalysisStyle.
Typically a polyface will contain only vertex data required for its basic display: the vertex position, normal
and possibly texture parameter. PolyfaceAuxData
provides supplemental data that is generally computed
in an analysis program or other external data source. This can be scalar data used to either override the vertex colors through, or
XYZ data used to deform the mesh by adjusting the vertex positions and/or normals.
see PolyfaceData.auxData to associate auxiliary data with a polyface.
Methods
Name | Description | |
---|---|---|
constructor(channels: AuxChannel[], indices: number[]): PolyfaceAuxData | ||
clone(): PolyfaceAuxData | Return a deep copy. | |
createForVisitor(): PolyfaceAuxData | Create a PolyfaceAuxData for use by a PolyfaceVisitor. | |
isAlmostEqual(other: PolyfaceAuxData, tolerance?: number): boolean | Returns true if this is equivalent to other within tolerance . |
|
tryTransformInPlace(transform: Transform): boolean | Apply transform to the data in each channel. |
|
isAlmostEqual(left: undefined | PolyfaceAuxData, right: undefined | PolyfaceAuxData, tol?: number): boolean Static | Returns true if both left and right are undefined, or both are defined and equivalent within tolerance (default: 1.0e-8). |
Properties
Name | Type | Description | |
---|---|---|---|
channels | AuxChannel[] | Array with one or more channels of auxiliary data for the associated polyface. | |
indices | number[] | The indices (shared by all data in all channels) mapping the data to the mesh facets. |
Defined in
- polyface/AuxData.ts Line 180
Last Updated: 20 June, 2023