AnalysisStyleDisplacement Class
Describes how an AnalysisStyle deforms a Polyface by applying translation to its vertices.
see AnalysisStyle.displacement.
Methods
Name | Description | |
---|---|---|
equals(other: AnalysisStyleDisplacement): boolean | Return true if this is equivalent to other . |
|
toJSON(): AnalysisStyleDisplacementProps | Convert to JSON representation. | |
fromJSON(props: AnalysisStyleDisplacementProps): AnalysisStyleDisplacement Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
channelName Readonly | string | The name of the AuxChannel supplying the displacements to be applied to the vertices. | |
scale Readonly | number | A scale applied to the displacements to adjust the magnitude of the effect. |
Defined in
- core/common/src/AnalysisStyle.ts Line 31
Last Updated: 20 June, 2023