AnalysisStyleThematic Class
Describes how an AnalysisStyle recolors Polyface vertices by mapping values of type AuxChannelDataType.Scalar or AuxChannelDataType.Distance supplied by an AuxChannel to colors supplied by a AnalysisStyleThematic.Gradient image.
Methods
Name | Description | |
---|---|---|
equals(other: AnalysisStyleThematic): boolean | Return true if this is equivalent to other . |
|
toJSON(): AnalysisStyleThematicProps | Convert to JSON representation. | |
fromJSON(props: AnalysisStyleThematicProps): AnalysisStyleThematic Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
channelName Readonly | string | The name of the AuxChannel supplying the values from which the vertex colors are computed. | |
gradient Accessor ReadOnly | Gradient.Symb | The gradient computed from AnalysisStyleThematic.thematicSettings. | |
range Readonly | Readonly<Range1d> | The minimum and maximum values that map to colors in the AnalysisStyleThematic.Gradient image. | |
thematicSettings Readonly | ThematicGradientSettings | Settings used to produce the AnalysisStyleThematic.Gradient image. |
Defined in
- core/common/src/AnalysisStyle.ts Line 87
Last Updated: 20 June, 2023