RenderSchedule.Script Class
Specifies how to animate the contents of a ViewState over time. The script contains any number of RenderSchedule.ModelTimelines, each describing how to animate one of the models in the view.
see RenderTimeline to create an Element to host a script.
see DisplayStyleSettings.renderTimeline to associate a RenderTimeline's script with a DisplayStyle.
see DisplayStyleState.scheduleScript to obtain the script associated with a display style.
see RenderSchedule.ScriptBuilder to define a new script.
Methods
Name | Description | |
---|---|---|
constructor(props: undefined): RenderSchedule.Script Protected | ||
compareTo(other: RenderSchedule.Script): number | ||
equals(other: RenderSchedule.Script): boolean | ||
find(modelId: string): undefined | RenderSchedule.ModelTimeline | Look up the timeline that animates the specified model, if any. | |
toJSON(): RenderSchedule.ScriptProps | ||
fromJSON(props: undefined): undefined | RenderSchedule.Script Static |
Properties
Name | Type | Description | |
---|---|---|---|
containsFeatureOverrides Readonly | boolean | True if this script affects the color or transparency of the geometry. | |
containsModelClipping Readonly | boolean | True if this script applies clipping to any models. | |
containsTransform Readonly | boolean | True if this script affects the position, orientation, or scale of the geometry. | |
duration Readonly | Range1d | The total time period over which this script animates. | |
modelTimelines Readonly | undefined | Timelines specifying how to animate individual models within the view. |
Defined in
- core/common/src/RenderSchedule.ts Line 1033
Last Updated: 20 June, 2023