renderTimeline
Accessor
The Id of a RenderTimeline element containing a RenderSchedule.Script used to animate the view. If DisplayStyleSettings.scheduleScriptProps is defined, it takes precedence over the script supplied by the RenderTimeline.
renderTimeline: undefined | string
note If this DisplayStyleSettings is associated with a DisplayStyleState, assigning to DisplayStyleSettings.renderTimeline will enqueue asynchronous loading of
the script from the RenderTimeline element; for more readable code, prefer instead to await
DisplayStyleState.changeRenderTimeline.
see DisplayStyleSettings.onRenderTimelineChanged to be notified of changes to this property.
Returns - undefined | string
Setter
The Id of a RenderTimeline element containing a RenderSchedule.Script used to animate the view. If DisplayStyleSettings.scheduleScriptProps is defined, it takes precedence over the script supplied by the RenderTimeline.
renderTimeline(id: undefined | string): void
note If this DisplayStyleSettings is associated with a DisplayStyleState, assigning to DisplayStyleSettings.renderTimeline will enqueue asynchronous loading of
the script from the RenderTimeline element; for more readable code, prefer instead to await
DisplayStyleState.changeRenderTimeline.
see DisplayStyleSettings.onRenderTimelineChanged to be notified of changes to this property.
Parameter | Type | Description |
---|---|---|
id | undefined | string |
Returns - void
Defined in
Last Updated: 20 June, 2023