scheduleScriptProps
Accessor
JSON representation of a RenderSchedule.Script embedded in the display style describing how to animate the contents of the view over time. This script, if present, takes precedence over a script supplied by DisplayStyleSettings.renderTimeline.
scheduleScriptProps: undefined | RenderSchedule.ScriptProps
see DisplayStyleSettings.onScheduleScriptPropsChanged to be notified when this property changes.
see DisplayStyleState.scheduleScript to change the RenderSchedule.Script object directly rather than via JSON.
Returns - undefined | RenderSchedule.ScriptProps
Setter
JSON representation of a RenderSchedule.Script embedded in the display style describing how to animate the contents of the view over time. This script, if present, takes precedence over a script supplied by DisplayStyleSettings.renderTimeline.
scheduleScriptProps(props: undefined | RenderSchedule.ScriptProps): void
see DisplayStyleSettings.onScheduleScriptPropsChanged to be notified when this property changes.
see DisplayStyleState.scheduleScript to change the RenderSchedule.Script object directly rather than via JSON.
Parameter | Type | Description |
---|---|---|
props | undefined | RenderSchedule.ScriptProps |
Returns - void
Defined in
Last Updated: 20 June, 2023