DynamicGraphicsRequestProps Interface
Wire format describing a request to produce graphics in "iMdl" format for a single geometry stream.
see DynamicGraphicsRequest2dProps and DynamicGraphicsRequest3dProps.
see ElementGraphicsRequestProps for more details.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
categoryId Readonly | string | The category to which the geometry belongs. | |
elementId Readonly | undefined | string | If specified, tools will recognize the generated graphics as being associated with this element. | |
geometry Readonly | JsonGeometryStream | FlatBufferGeometryStream | The geometry from which to generate the graphics. | |
modelId Readonly | undefined | string | If specified, tools will recognize the generated graphics as being associated with this model. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
clipToProjectExtents Readonly | undefined | boolean | GraphicsRequestProps | If true, the element's graphics will be clipped against the iModel's project extents. |
contentFlags Readonly | undefined | | GraphicsRequestProps | Optional flags. |
formatVersion Readonly | undefined | number | GraphicsRequestProps | The major version of the "iMdl" format to use when producing the iMdl representation of the element's geometry. |
id Readonly | string | GraphicsRequestProps | Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel. |
location Readonly | undefined | TransformProps | GraphicsRequestProps | Transform from element graphics to world coordinates. |
omitEdges Readonly | undefined | boolean | GraphicsRequestProps | If true, surface edges will be omitted from the graphics. |
quantizePositions | undefined | boolean | GraphicsRequestProps | If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision. |
sectionCut Readonly | undefined | string | GraphicsRequestProps | If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut |
toleranceLog10 Readonly | number | GraphicsRequestProps | Log10 of the chord tolerance with which to stroke the element's geometry. |
treeFlags Readonly | undefined | | GraphicsRequestProps | Optional flags. |
useAbsolutePositions | undefined | boolean | GraphicsRequestProps | Determines whether unquantized positions are specified in relative or absolute coordinates. |
Defined in
Last Updated: 20 June, 2023