GraphicsRequestProps Interface
Wire format describing properties common to PersistentGraphicsRequestProps and DynamicGraphicsRequestProps.
see ElementGraphicsRequestProps for more details.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
clipToProjectExtents Readonly | undefined | boolean | If true, the element's graphics will be clipped against the iModel's project extents. | |
contentFlags Readonly | undefined | | Optional flags. | |
formatVersion Readonly | undefined | number | The major version of the "iMdl" format to use when producing the iMdl representation of the element's geometry. | |
id Readonly | string | Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel. | |
location Readonly | undefined | TransformProps | Transform from element graphics to world coordinates. | |
omitEdges Readonly | undefined | boolean | If true, surface edges will be omitted from the graphics. | |
quantizePositions | undefined | boolean | If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision. | |
sectionCut Readonly | undefined | string | If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut | |
toleranceLog10 Readonly | number | Log10 of the chord tolerance with which to stroke the element's geometry. | |
treeFlags Readonly | undefined | | Optional flags. | |
useAbsolutePositions | undefined | boolean | Determines whether unquantized positions are specified in relative or absolute coordinates. |
Defined in
Last Updated: 20 June, 2023