DynamicGraphicsRequest3dProps Interface
Wire format describing a request to produce graphics in "iMdl" format for a 3d geometry stream.
see ElementGraphicsRequestProps for more details.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
placement Readonly | Omit<Placement3dProps, "bbox"> | The origin and rotation of the geometry. | |
type Readonly | "3d" | Specifies the geometry is 3d. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categoryId Readonly | string | DynamicGraphicsRequestProps | The category to which the geometry belongs. |
clipToProjectExtents Readonly | undefined | boolean | DynamicGraphicsRequestProps | If true, the element's graphics will be clipped against the iModel's project extents. |
contentFlags Readonly | undefined | | DynamicGraphicsRequestProps | Optional flags. |
elementId Readonly | undefined | string | DynamicGraphicsRequestProps | If specified, tools will recognize the generated graphics as being associated with this element. |
formatVersion Readonly | undefined | number | DynamicGraphicsRequestProps | The major version of the "iMdl" format to use when producing the iMdl representation of the element's geometry. |
geometry Readonly | JsonGeometryStream | FlatBufferGeometryStream | DynamicGraphicsRequestProps | The geometry from which to generate the graphics. |
id Readonly | string | DynamicGraphicsRequestProps | Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel. |
location Readonly | undefined | TransformProps | DynamicGraphicsRequestProps | Transform from element graphics to world coordinates. |
modelId Readonly | undefined | string | DynamicGraphicsRequestProps | If specified, tools will recognize the generated graphics as being associated with this model. |
omitEdges Readonly | undefined | boolean | DynamicGraphicsRequestProps | If true, surface edges will be omitted from the graphics. |
quantizePositions | undefined | boolean | DynamicGraphicsRequestProps | If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision. |
sectionCut Readonly | undefined | string | DynamicGraphicsRequestProps | If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut |
toleranceLog10 Readonly | number | DynamicGraphicsRequestProps | Log10 of the chord tolerance with which to stroke the element's geometry. |
treeFlags Readonly | undefined | | DynamicGraphicsRequestProps | Optional flags. |
useAbsolutePositions | undefined | boolean | DynamicGraphicsRequestProps | Determines whether unquantized positions are specified in relative or absolute coordinates. |
Defined in
Last Updated: 20 June, 2023