QPoint3dBufferBuilder Class
Constructs a QPoint3dBuffer using a Uint16ArrayBuilder.
extensions
Methods
Name | Description | |
---|---|---|
constructor(options: QPoint3dBufferBuilderOptions): QPoint3dBufferBuilder | Construct a new buffer with a QPoint3dBufferBuilder.length of zero. | |
finish(): QPoint3dBuffer | Obtain a QPoint3dBuffer containing all of the points that have been appended by this builder. | |
get(pointIndex: number, result?: QPoint3d): QPoint3d | Returns the quantized point at the specified index in QPoint3dBufferBuilder.buffer. | |
push(pt: Readonly<WritableXYAndZ>): void | Append a point with the specified quantized coordinates. | |
pushXYZ(x: number, y: number, z: number): void | Append a point with the specified quantized coordinates. | |
unquantize(pointIndex: number, result?: Point3d): Point3d | Returns the unquantized point at the specified index in QPoint3dBufferBuilder.buffer. |
Properties
Name | Type | Description | |
---|---|---|---|
buffer Readonly | Uint16ArrayBuilder | The buffer that holds the points. | |
length Accessor ReadOnly | number | The number of points currently in the QPoint3dBufferBuilder.buffer. | |
params Readonly | QParams3d | The parameters used to quantize the points in the QPoint3dBufferBuilder.buffer. |
Defined in
- core/common/src/QPoint.ts Line 929
Last Updated: 20 June, 2023