QPoint3dBuffer Namespace
Function
Name | Description |
---|---|
QPoint3dBuffer.getQPoint | Extracts the point at the specified index from a buffer. |
QPoint3dBuffer.unquantizePoint | Extracts and unquantizes the point at the specified index from a buffer. |
Defined in
- core/common/src/QPoint.ts Line 656
QPoint3dBuffer Interface
A compact representation of a list of QPoint3ds stored in a Uint16Array
.
This representation is particularly useful when passing data to WebGL; for example, see RealityMeshParams.positions.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
params | QParams3d | The parameters used to quantize the QPoint3dBuffer.points. | |
points | Uint16Array | The QPoint3ds as pairs of unsigned 16-bit integers. |
Defined in
- core/common/src/QPoint.ts Line 644
Last Updated: 20 June, 2023