GridFileTransform Class
This class represents a grid files based geodetic transformation.
Implements
Methods
Name | Description | |
---|---|---|
constructor(data?: GridFileTransformProps): GridFileTransform | ||
equals(other: GridFileTransform): boolean | Compares two Grid File Transforms. | |
toJSON(): GridFileTransformProps | Creates a JSON from the Grid File Transform definition | |
fromJSON(data: GridFileTransformProps): GridFileTransform Static | Creates a Grid File Transform from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
fallback Readonly | undefined | PositionalVectorTransform | The positional vector fallback transformation used for extents not covered by the grid files | |
files Readonly | GridFileDefinition[] | The list of grid files. |
Defined in
Last Updated: 20 June, 2023