CreateIModelProps Interface
The properties that can be supplied when creating a new iModel.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
client Readonly | undefined | string | Client name for new iModel | |
guid Readonly | undefined | string | The GUID of new iModel. | |
thumbnail Readonly | undefined | ThumbnailProps | Thumbnail for new iModel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
ecefLocation Readonly | undefined | EcefLocationProps | IModelProps | The location of the iModel in Earth Centered Earth Fixed coordinates. |
geographicCoordinateSystem Readonly | undefined | GeographicCRSProps | IModelProps | The Geographic Coordinate Reference System indicating the projection and datum used. |
globalOrigin Readonly | undefined | XYZProps | IModelProps | An offset to be applied to all spatial coordinates. |
name Readonly | undefined | string | IModelProps | The name of the iModel. |
projectExtents Readonly | undefined | Range3dProps | IModelProps | The volume of the entire project, in spatial coordinates |
rootSubject Readonly | RootSubjectProps | IModelProps | The name and description of the root subject of this iModel |
Defined in
- core/common/src/IModel.ts Line 112
Last Updated: 20 June, 2023