IModelProps Interface
Properties of an iModel that are always held in memory whenever one is opened, both on the frontend and on the backend .
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
ecefLocation Readonly | undefined | EcefLocationProps | The location of the iModel in Earth Centered Earth Fixed coordinates. | |
geographicCoordinateSystem Readonly | undefined | GeographicCRSProps | The Geographic Coordinate Reference System indicating the projection and datum used. | |
globalOrigin Readonly | undefined | XYZProps | An offset to be applied to all spatial coordinates. | |
name Readonly | undefined | string | The name of the iModel. | |
projectExtents Readonly | undefined | Range3dProps | The volume of the entire project, in spatial coordinates | |
rootSubject Readonly | RootSubjectProps | The name and description of the root subject of this iModel |
Defined in
- core/common/src/IModel.ts Line 87
Last Updated: 20 June, 2023