PhysicalTypeProps Interface
Properties of a PhysicalType
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
physicalMaterial | undefined | RelatedElementProps | The PhysicalMaterial that makes up this physical type. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | TypeDefinitionElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | TypeDefinitionElementProps | The Code for this element |
federationGuid | undefined | string | TypeDefinitionElementProps | A FederationGuid assigned to this element. |
id | undefined | string | TypeDefinitionElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | TypeDefinitionElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | TypeDefinitionElementProps | |
jsonProperties | undefined | any | TypeDefinitionElementProps | Optional json properties of this element. |
model | string | TypeDefinitionElementProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | TypeDefinitionElementProps | The Parent of this element, if defined. |
recipe | undefined | RelatedElementProps | TypeDefinitionElementProps | |
userLabel | undefined | string | TypeDefinitionElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 320
Last Updated: 20 June, 2023