ModelGeometryChangesProps Interface
Compact wire format representing geometric changes to GeometricElements within a GeometricModel. A given element Id will appear in no more than one of ModelGeometryChangesProps.inserted, ModelGeometryChangesProps.updated, or ModelGeometryChangesProps.deleted.
see ModelGeometryChanges for a more useful representation.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
deleted Readonly | undefined | string | If defined, the Ids of deleted GeometricElements. | |
guid Readonly | string | The geometry GUID of the model. | |
id Readonly | string | The Id of the model. | |
inserted Readonly | undefined | ElementIdsAndRangesProps | If defined, the Ids and ranges of newly-inserted GeometricElements. | |
range Readonly | Range3dProps | The range of the model, computed as the union of the ranges of all geometric elements within the model. | |
updated Readonly | undefined | ElementIdsAndRangesProps | If defined, the Ids and ranges of GeometricElements whose geometric properties were modified. |
Defined in
Last Updated: 20 June, 2023