ElementIdsAndRangesProps Interface
Compact wire format representing geometric changes to a set of elements as part of a ModelGeometryChangesProps. All of the elements belong to the same model. The number of ElementIdsAndRangesProps.ids and ElementIdsAndRangesProps.ranges are guaranteed to be the same.
see ElementGeometryChange for a more useful representation of an individual element change.
see ModelGeometryChanges.iterable to iterate over ElementGeometryChanges.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
ids Readonly | string | The Ids of the elements, compressed and sorted in ascending order. | |
ranges Readonly | Range3dProps[] | The range of each element, indexed by the position of the corresponding element's Id in ElementIdsAndRangesProps.ids. |
Defined in
Last Updated: 20 June, 2023