GeometricModel Class
A container for persisting geometric elements.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
queryExtents(): Range3d | Query for the union of the extents of the elements contained by this model. | |
queryRange(): Promise<Range3d> | Query for the union of the extents of all elements contained within this model. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | Model | Collect the Ids of this entity's references at this level of the class hierarchy. |
delete(): void | Model | Delete this Model from the iModel. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | Model | Call a function for each property of this Entity. |
getJsonProperty(name: string): any | Model | |
getReferenceIds(): Set<string> | Model | Get the Ids of this element's references. |
getUserProperties(namespace: string): any | Model | Get a set of JSON user properties by namespace |
insert(): string | Model | Insert this Model in the iModel |
removeUserProperties(nameSpace: string): void | Model | Remove a set of JSON user properties, specified by namespace, from this Element |
setJsonProperty(name: string, value: any): void | Model | |
setUserProperties(nameSpace: string, value: any): void | Model | Change a set of user JSON properties of this Element by namespace. |
update(): void | Model | Update this Model in the iModel. |
is(otherClass: undefined): boolean Static | Model | return whether this Entity class is a subclass of another Entity class |
onDelete(arg: OnModelIdArg): void ProtectedStatic | Model | Called before a Model is deleted. |
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic | Model | Called when an Element in an instance of a Model of this class is about to be deleted. |
onDeleted(_arg: OnModelIdArg): void ProtectedStatic | Model | Called after a Model was deleted. |
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | Model | Called after an Element in an instance of a Model of this class has been deleted. |
onInsert(arg: OnModelPropsArg): void ProtectedStatic | Model | Called before a new Model is inserted. |
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | Model | Called before a prospective Element is to be inserted into an instance of a Model of this class. |
onInserted(_arg: OnModelIdArg): void ProtectedStatic | Model | Called after a new Model is inserted. |
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | Model | Called after an Element has been inserted into an instance of a Model of this class. |
onUpdate(arg: OnModelPropsArg): void ProtectedStatic | Model | Called before a Model is updated. |
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic | Model | Called when an Element in an instance of a Model of this class is about to be updated. |
onUpdated(_arg: OnModelIdArg): void ProtectedStatic | Model | Called after a Model is updated. |
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic | Model | Called after an Element in an instance of a Model of this class has been updated. |
Properties
Name | Type | Description | |
---|---|---|---|
geometryGuid | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | Model | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | Model | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | Model | The name of the BIS class associated with this class. |
id | string | Model | The Id of this Entity. |
iModel | IModelDb | Model | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | Model | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
isPrivate | boolean | Model | |
isTemplate | boolean | Model | |
jsonProperties Readonly | { T } | Model | |
modeledElement Readonly | RelatedElement | Model | |
name Readonly | string | Model | |
parentModel Readonly | string | Model | |
schema Static | undefined | Model | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | Model | The name of the BIS Schema that defines this class |
Defined in
- backend/src/Model.ts Line 237
Last Updated: 20 June, 2023