OnElementInModelPropsArg Interface
Beta
Argument for the Model.onXxxElement
static methods that supply the properties of an Element for a Model.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
elementProps | Readonly<ElementProps> | The new properties of an Element for the affected Model |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
iModel | IModelDb | OnModelIdArg | The iModel for the Model affected. |
id | string | OnModelIdArg | The Id of the Model affected |
Defined in
- backend/src/Model.ts Line 49
Last Updated: 20 June, 2023