FeatureAppearanceSource Interface
Interface adopted by an object that can supply a FeatureAppearance given a low-level description of a Feature.
see FeatureOverrides for the commonly-used implementation.
see FeatureAppearanceProvider to supplement the appearance supplied by this interface.
extensions
Implemented by
Methods
Name | Description | |
---|---|---|
getAppearance(elemLo: number, elemHi: number, subcatLo: number, subcatHi: number, geomClass: GeometryClass, modelLo: number, modelHi: number, type: BatchType, animationNodeId: number): undefined | FeatureAppearance | Supplies the desired appearance overrides for the specified Feature, or undefined if the feature should not be drawn. |
Defined in
- core/common/src/FeatureSymbology.ts Line 293
Last Updated: 20 June, 2023