FeatureAppearanceProvider Namespace
Function
Name | Description |
---|---|
FeatureAppearanceProvider.chain | Chain two FeatureAppearanceProviders together such that first 's getFeatureAppearance function is applied before second 's. |
FeatureAppearanceProvider.supplement | Create a provider that obtains each feature's appearance from the source, and if the feature is visible, modifies the appearance. |
Defined in
- core/common/src/FeatureSymbology.ts Line 844
FeatureAppearanceProvider Interface
Interface adopted by an object that can supply the FeatureAppearance supplied by a FeatureAppearanceSource. This is useful for selectively overriding or agumenting a Viewport's symbology overrides. A typical implementation will invoke FeatureAppearanceSource.getAppeaprance and customize the returned appearance.
see FeatureAppearanceProvider.chain to chain two providers together.
extensions
Methods
Name | Description | |
---|---|---|
getFeatureAppearance(source: FeatureAppearanceSource, elemLo: number, elemHi: number, subcatLo: number, subcatHi: number, geomClass: GeometryClass, modelLo: number, modelHi: number, type: BatchType, animationNodeId: number): undefined | FeatureAppearance | Supply the desired appearance overrides for the specified Feature, or undefined if the feature should not be drawn. |
Defined in
- core/common/src/FeatureSymbology.ts Line 823
Last Updated: 20 June, 2023