TxnAction Enumeration
Describes the types of actions associated with Txns.
extensions
Members
Name | Value | Description |
---|---|---|
None | 0 | Not currently processing anything. |
Commit | 1 | Processing a commit initiated by a call to IModelDb.saveChanges or BriefcaseConnection.saveChanges. |
Abandon | 2 | Abandoning the current Txn, e.g., via IModelDb.abandonChanges. |
Reverse | 3 | Reversing a previously-committed changeset, e.g., via TxnManager.reverseTxns BriefcaseTxns.reverseTxns. |
Reinstate | 4 | Reinstating a previously reversed changeset, e.g., via TxnManager.reinstateTxn or BriefcaseTxns.reinstateTxn. |
Merge | 5 | Merging a changeset produced by a different briefcase, e.g., via BriefcaseDb.pullChanges. |
Defined in
- core/common/src/TxnAction.ts Line 13
Last Updated: 20 June, 2023