reverseTxns Method
Reverse (undo) the most recent operation(s) to this IModelDb.
reverseTxns(numOperations: number): IModelStatus
note If there are any outstanding uncommitted changes, they are reversed.
note The term "operation" is used rather than Txn, since multiple Txns can be grouped together via TxnManager.beginMultiTxnOperation. So, even if numOperations is 1, multiple Txns may be reversed if they were grouped together when they were made.
note If numOperations is too large only the operations are reversible are reversed.
Returns - IModelStatus
Defined in
- backend/src/TxnManager.ts Line 395
Last Updated: 20 June, 2023