GeometricModel2dProps Interface
Properties that define a GeometricModel2d
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
globalOrigin | undefined | XYProps | The actual coordinates of (0,0) in modeling coordinates. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | GeometricModelProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
geometryGuid | undefined | string | GeometricModelProps | A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model |
id | undefined | string | GeometricModelProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | GeometricModelProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | GeometricModelProps | |
isTemplate | undefined | boolean | GeometricModelProps | |
jsonProperties | undefined | any | GeometricModelProps | Optional json properties of this Entity. |
modeledElement | RelatedElementProps | GeometricModelProps | |
name | undefined | string | GeometricModelProps | |
parentModel | undefined | string | GeometricModelProps |
Defined in
- core/common/src/ModelProps.ts Line 64
Last Updated: 20 June, 2023