GeometricModelProps Interface
Properties that describe a GeometricModel
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
geometryGuid | undefined | string | A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ModelProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | undefined | string | ModelProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ModelProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | ModelProps | |
isTemplate | undefined | boolean | ModelProps | |
jsonProperties | undefined | any | ModelProps | Optional json properties of this Entity. |
modeledElement | RelatedElementProps | ModelProps | |
name | undefined | string | ModelProps | |
parentModel | undefined | string | ModelProps |
Defined in
- core/common/src/ModelProps.ts Line 51
Last Updated: 20 June, 2023