ModelProps Interface
Properties that define a Model
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
isPrivate | undefined | boolean | ||
isTemplate | undefined | boolean | ||
jsonProperties | undefined | any | Optional json properties of this Entity. | |
modeledElement | RelatedElementProps | ||
name | undefined | string | ||
parentModel | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | undefined | string | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
Defined in
- core/common/src/ModelProps.ts Line 19
Last Updated: 20 June, 2023