ImageGraphicCorners Class
Defines the 4 corners of an ImageGraphic. The points are expected to lie in a single plane and define a (possibly-skewed) quadrilateral.
The points map to the corners of the image as follows:
3____2 | | |____| 0 1
The image can be flipped and/or rotated by specifying the points in a different order.
Methods
Name | Description | |
---|---|---|
constructor(p0: Point3d, p1: Point3d, p2: Point3d, p3: Point3d): ImageGraphicCorners | ||
clone(): ImageGraphicCorners | ||
toJSON(): ImageGraphicCornersProps | ||
from4Points(points: [Point3d, Point3d, Point3d, Point3d]): ImageGraphicCorners Static | ||
fromJSON(props: ImageGraphicCornersProps): ImageGraphicCorners Static |
Properties
Name | Type | Description | |
---|---|---|---|
0 Readonly | Point3d | ||
1 Readonly | Point3d | ||
2 Readonly | Point3d | ||
3 Readonly | Point3d |
Defined in
Last Updated: 20 June, 2023