ImageGraphic Class
A geometric primitive that displays an image mapped to the corners of a quadrilateral, with an optional border. The image is always displayed regardless of RenderMode or ViewFlags, and is displayed without lighting.
Methods
Name | Description | |
---|---|---|
constructor(corners: ImageGraphicCorners, textureId: string, hasBorder: boolean = false): ImageGraphic | Construct a new ImageGraphic. | |
clone(): ImageGraphic | ||
cloneTransformed(transform: Transform): ImageGraphic | ||
computeRange(result?: Range3d): Range3d | Computes and returns the range. | |
toJSON(): ImageGraphicProps | ||
transformInPlace(transform: Transform): void | Apply a transform to the corners of the quadrilateral. | |
fromJSON(props: ImageGraphicProps): ImageGraphic Static |
Properties
Name | Type | Description | |
---|---|---|---|
corners Readonly | ImageGraphicCorners | The 4 corners of defining the quadrilateral on which the image is displayed. | |
hasBorder Readonly | boolean | Whether or not to draw a border around the image. | |
textureId Readonly | string | The Id of the persistent Texture element defining the image to be displayed on the quadrilateral. |
Defined in
Last Updated: 20 June, 2023