ThematicDisplaySensor Class
A sensor in world space, used for ThematicDisplayMode.InverseDistanceWeightedSensors.
Methods
Name | Description | |
---|---|---|
equals(other: ThematicDisplaySensor): boolean | ||
toJSON(): ThematicDisplaySensorProps | ||
fromJSON(json?: ThematicDisplaySensorProps): ThematicDisplaySensor Static |
Properties
Name | Type | Description | |
---|---|---|---|
position | Readonly<Point3d> | The world position of the sensor in X, Y, and Z. | |
value Readonly | number | The value of the sensor used when accessing the thematic gradient texture; expected range is 0 to 1. |
Defined in
- core/common/src/ThematicDisplay.ts Line 251
Last Updated: 20 June, 2023