RenderTexture Namespace
Enumeration
Name | Description |
---|---|
RenderTexture.Type | The types of RenderTextures that can be created by a RenderSystem. |
Class
Name | Description |
---|---|
RenderTexture.Params | Parameters used to construct a RenderTexture. |
Defined in
- core/common/src/RenderTexture.ts Line 47
RenderTexture Class
Represents a texture image applied to a surface during rendering. A RenderTexture is typically - but not always - associated with a RenderMaterial.
see RenderSystem.createTextureFromImage to obtain a texture from an HTML image.
see RenderSystem.createTextureFromElement to obtain a texture from a Texture element.
Implements
Methods
Name | Description | |
---|---|---|
constructor(type: RenderTexture.Type): RenderTexture Protected | ||
dispose(): void Abstract | Releases any WebGL resources owned by this texture. |
Properties
Name | Type | Description | |
---|---|---|---|
bytesUsed Accessor AbstractReadOnly | number | ||
isGlyph Accessor ReadOnly | boolean | ||
isSkyBox Accessor ReadOnly | boolean | ||
isTileSection Accessor ReadOnly | boolean | ||
type Readonly | RenderTexture.Type | Indicates the type of texture. |
Defined in
- core/common/src/RenderTexture.ts Line 25
Last Updated: 20 June, 2023