RenderMaterial Namespace
Class
Defined in
RenderMaterial Class
Represents a material which can be applied to a surface to control aspects of its appearance such as color, reflectivity, texture, and so on.
Methods
Properties
Name |
Type |
Description |
|
hasTexture Accessor ReadOnly |
boolean |
|
|
key Readonly |
undefined | string |
If the material originated from a Material element in the IModelDb, the Id of that element. |
|
textureMapping Readonly |
undefined | TextureMapping |
Describes how to map an image to a surface to which this material is applied. |
|
Defined in
Last Updated:
20 June, 2023