RenderMaterial.Params Class
Methods
Properties
Name |
Type |
Description |
|
alpha Accessor |
undefined | number |
A value from 0.0 (fully-transparent) to 1.0 (fully-opaque) controlling the transparency of surfaces to which this material is applied; |
|
ambient |
number |
Currently unused. |
|
defaults StaticReadonly |
RenderMaterial.Params |
Obtain an immutable instance of a RenderMaterial with all default properties. |
|
diffuse |
number |
Diffuse weight in [0..1] |
|
diffuseColor |
undefined | ColorDef |
Diffuse color, or undefined if this material does not override the surface's own color. |
|
emissiveColor |
undefined | ColorDef |
Currently unused. |
|
key |
undefined | string |
If the material originates from a Material element in the IModel, the Id of that element. |
|
reflect |
number |
Currently unused. |
|
reflectColor |
undefined | ColorDef |
Currently unused. |
|
refract |
number |
Currently unused. |
|
shadows |
boolean |
Currently unused. |
|
specular |
number |
Specular weight in [0..1] |
|
specularColor |
undefined | ColorDef |
Specular color. |
|
specularExponent |
number |
|
|
textureMapping |
undefined | TextureMapping |
Optional pattern mapping applied to the surface. |
|
Defined in
Last Updated:
20 June, 2023