CreateRenderMaterialArgs Interface
Arguments supplied to RenderSystem.createRenderMaterial.
Properties
Name | Type | Description | |
---|---|---|---|
alpha | undefined | number | Specifies the transparency of the material from 0.0 (fully transparent) to 1.0 (fully opaque). | |
diffuse | undefined | MaterialDiffuseProps | The diffuse properties of the material. | |
specular | undefined | MaterialSpecularProps | The specular properties of the material. | |
textureMapping | undefined | MaterialTextureMappingProps | Maps RenderTexture images to the surfaces to which the material is applied to customize their appearance. |
Defined in
Last Updated: 20 June, 2023