MaterialTextureMappingProps Interface
Describes how to map a RenderTexture's image to the surfaces to which a RenderMaterial is applied.
see CreateRenderMaterialArgs.textureMapping.
Properties
Name | Type | Description | |
---|---|---|---|
mode | undefined | Mode | The mode controlling how the image is mapped onto the surface. | |
normalMapParams | undefined | NormalMapParams | The parameters describing a normal map to use either in place of or in addition to the texture. | |
texture | RenderTexture | The texture from which the image is obtained. | |
transform | undefined | Trans2x3 | A 2x3 matrix for computing the UV coordinates. | |
weight | undefined | number | The ratio by which the color sampled from the texture image is mixed with the surface's or material's diffuse color. |
Defined in
Last Updated: 20 June, 2023