RenderMaterialAssetMapsProps Interface
Describes different types of textures to be applied to a surface material to alter its appearance.
note While technically both RenderMaterialAssetMapsProps.Pattern and RenderMaterialAssetMapsProps.Normal can define their own mapping parameters (pattern_angle
, pattern_mapping
, etc), in practice
if both maps are present they are expected to have identical mapping parameters, with the exception of TextureId
.
see RenderMaterialAssetProps.Map to define the texture maps for a material asset.
Properties
Name | Type | Description | |
---|---|---|---|
Normal | undefined | NormalMapProps | Maps a normal map to the surface, simulating more complex surface details than are | |
Pattern | undefined | TextureMapProps | Maps an image describing the diffuse color of the surface, replacing or mixing with the surface's own color. |
Defined in
- core/common/src/MaterialProps.ts Line 96
Last Updated: 20 June, 2023