NormalMapProps Interface
Describes how to apply normal mapping to a surface material.
see RenderMaterialAssetMapsProps.Normal to define a normal map for a RenderMaterialAssetProps.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
NormalFlags | undefined | NormalMapFlags | Flags controlling how the normal map is applied. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
TextureId | string | TextureMapProps | The Id of the persistent Texture element defining the texture image. |
pattern_angle | undefined | number | TextureMapProps | Angle in degrees to rotate texture when applying; defaults to 0.0 if undefined |
pattern_flip | undefined | boolean | TextureMapProps | If true, flip the pattern map in V; if undefined, defaults to false |
pattern_mapping | undefined | TextureMapping.Mode | TextureMapProps | Mapping mode to use for the texture application; if undefined, defaults to TextureMapping.Mode.Parametric |
pattern_offset | undefined | Point2dProps | TextureMapProps | X, Y offset to apply to the pattern map; if undefined, defaults to {0,0} |
pattern_scale | undefined | Point2dProps | TextureMapProps | X, Y scale to apply to the pattern map; if undefined, defaults to {0,0}, which is almost never useful. |
pattern_scalemode | undefined | TextureMapUnits | TextureMapProps | Units to use when applying the scaling; if undefined, defaults to TextureMapUnits.Relative |
pattern_u_flip | undefined | boolean | TextureMapProps | If true, flip the pattern map in U; if undefined, defaults to false |
pattern_weight | undefined | number | TextureMapProps | Weight at which to combine diffuse image and color; if undefined, defaults to 1.0 |
Defined in
- core/common/src/MaterialProps.ts Line 85
Last Updated: 20 June, 2023