BentleyCloudRpcConfiguration Class
Beta
Operating parameters for Bentley cloud RPC interface deployments.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): BentleyCloudRpcConfiguration |
Inherited methods
Name | Inherited from | Description |
---|---|---|
assignWithRouting<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>, routing: RpcRoutingToken, configuration: () => RpcConfiguration): void Static | RpcConfiguration | Sets the configuration supplier for an RPC interface class for a given routing. |
initializeInterfaces(configuration: RpcConfiguration): void Static | RpcConfiguration | Initializes the RPC interfaces managed by the configuration. |
obtain<T extends RpcConfiguration<T>>(configurationConstructor: () => T): T Static | RpcConfiguration | Obtains the instance of an RPC configuration class. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
developmentMode Static | boolean | RpcConfiguration | Whether development mode is enabled. |
disableRoutingValidation Static | boolean | RpcConfiguration | Whether frontend checks that are relevant in a cloud-hosted routing scenario are disabled. |
interfaces AbstractReadonly | () => RpcInterfaceDefinition<RpcInterface>[] | RpcConfiguration | |
pendingOperationRetryInterval | number | RpcConfiguration | The target interval (in milliseconds) between connection attempts for pending RPC operation requests. |
strictMode Static | boolean | RpcConfiguration | Whether strict mode is enabled. |
throwOnTokenMismatch Static | boolean | RpcConfiguration | Whether to throw an error when the IModelRpcProps in the operation parameter list differs from the token in the URL. |
transientFaultLimit | number | RpcConfiguration | The maximum number of transient faults permitted before request failure. |
Defined in
Last Updated: 20 June, 2023