ElementMeshRequestProps Interface
Beta
Describes a request to generate Polyfaces from an element.
see IModelConnection.generateElementMeshes.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
source | string | The Id of the GeometricElement from which to obtain meshes. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
angleTolerance | undefined | number | ElementMeshOptions | Maximum angle difference in radians for an approximated face. |
chordTolerance | undefined | number | ElementMeshOptions | Maximum distance from a face to the original geometry. |
minBRepFeatureSize | undefined | number | ElementMeshOptions | BRep features with bounding boxes smaller than this size will not generate graphics. |
Defined in
- core/common/src/ElementMesh.ts Line 38
Last Updated: 20 June, 2023