Placement2d Class
The placement of a GeometricElement2d. This includes the origin, rotation, and size (bounding box) of the element.
Implements
Methods
Name | Description | |
---|---|---|
constructor(origin: Point2d, angle: Angle, bbox: Range2d): Placement2d | ||
calculateRange(): Range3d | Calculate the axis-aligned bounding box for this placement. | |
getWorldCorners(out?: Frustum): Frustum | Get the 8 corners, in world coordinates, of this placement. | |
multiplyTransform(other: Transform): void | Multiply the Transform of this Placement2d by the specified other Transform. | |
setFrom(other: Placement2d): void | Set the contents of this Placement2d from another Placement2d | |
fromJSON(json?: Placement2dProps): Placement2d Static | Create a new Placement2d from a Placement2dProps. |
Properties
Name | Type | Description | |
---|---|---|---|
angle | Angle | ||
bbox | Range2d | ||
is3d Accessor ReadOnly | boolean | determine if this is 3d placement | |
isValid Accessor ReadOnly | boolean | Determine whether this Placement2d is valid. | |
origin | Point2d | ||
rotation Accessor ReadOnly | Matrix3d | Get the rotation from local coordinates of this placement to world coordinates. | |
transform Accessor ReadOnly | Transform | Get the transform from local coordinates of this placement to world coordinates. |
Defined in
Last Updated: 20 June, 2023