QueryOptions Interface
ECSql query config
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
abbreviateBlobs | undefined | boolean | default to false. | |
convertClassIdsToClassNames | undefined | boolean | Convert ECClassId, SourceECClassId, TargetECClassId and RelClassId to respective name. | |
includeMetaData | undefined | boolean | This is used internally. | |
limit | undefined | QueryLimit | Limit range of rows returned by query | |
rowFormat | undefined | QueryRowFormat | Determine row format. | |
suppressLogErrors | undefined | boolean | default to false. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
priority | undefined | number | BaseReaderOptions | Determine priority of this query default to 0, used as hint and can be overriden by backend. |
quota | undefined | QueryQuota | BaseReaderOptions | Restrict time or memory for query but use as hint and may be changed base on backend settings |
restartToken | undefined | string | BaseReaderOptions | If specified cancel last query (if any) with same restart token and queue the new query |
usePrimaryConn | undefined | boolean | BaseReaderOptions | For editing apps this can be set to true and all query will run on primary connection |
Defined in
- core/common/src/ConcurrentQuery.ts Line 101
Last Updated: 20 June, 2023